Cacti Error XML hash version does not exist

I thought I would write a quick post on this error, it is very simple to fix. If you receive the following error when importing a Cacti Template:

Error: XML: Hash version does not exist

This simply means the template was generated on a version of Cacti newer than the one you are importing to. Don’t despair, there are simple upgrade instructions on the cacti website.

Just make sure you make a full backup of your database and Cacti webfiles before attempting the upgrade (As a cautionary tale, if you installed cacti from a package you should first check to see if an updated package is available. Package installs can sometimes put the different files required in different places)

This entry was posted in Cacti, Sys Admin and tagged , . Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *